WordPress plugins and themes

Fix for Warning: json_encode() expects exactly 1 parameter, 2 given

If you have installed oik-nivo-slider version 1.7 and oik version 1.17 AND are running your website on a version of PHP lower than 5.3.3, then you could get the following Warning message from the [nivo] shortcode.

Warning: json_encode() expects exactly 1 parameter, 2 given in /wp-content/plugins/oik/bobbfunc.inc on line

This post offers three solutions.

Not recommended
Fix the code yourself. Not recommended – but it was the first solution given in the forum
Proposed solution
Install the latest version of oik, using the oik options > Plugins admin pages.

See Upgrade to a new version of oik from oik-plugins

Longer term
Upgrade your version of PHP to 5.3.3 or higher.

This is the best long term solution as this will allow the oik base plugin to use the functionality implemented in PHP 5.3.3 for the json_encode() API

Recent plugin updates
oik-bwtrace v1.26 Improved logic for self implementation as an MU plugin. Please update the oik base plugin to v2.6-alpha.0525 or higher before updating oik-bwtrace.  ...
oik v2.6-alpha.0525 Contains changes required by oik-bwtrace v1.25 ...
oik-clone v1.0-beta.0601 Improved discovery of target post using slug. ...
oik-bwtrace v1.25 Improved support for action hooks and filters. Now implements itself as a Must Use (MU) plugin if action counting is selected. Please update the oik base plugin to 2.6-alpha.0525 or higher before updating to oik-bwtrace v1.25.  ...
oik-bwtrace v1.24 Upgrade to get remote IP address in the summary log  ...